Categories
blog

Heroku “Failed to download a Ruby executable for bootstrapping”

A quick note which will hopefully help someone else who came across the same issue as me.

When updating heroku’s Ruby version from the heroku-18 to the heroku-20 stack, any custom buildpacks will need to be rewritten or replaced.

I had an issue with the -18 buildpack requiring me to use this custom buildpack (supporting some Yarn feature or other):

However, it caused an error when deploying immediately after upgrading the Heroku stack version.

You may see an error like this:

Simplest way to fix the *deploy_ problem is to remote the buildpack from your heroku app settings. This won’t solve the reason you had to use the buildpack in the first place, but it’ll help you get there.